[PEPr] Comment on File Formats::File_Karma

From: Date: Tue, 23 Aug 2005 05:37:35 +0000
Subject: [PEPr] Comment on File Formats::File_Karma
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-39502@lists.php.net to get a copy of this message
Joe Stump (http://pear.php.net/user/jstump) has commented on the proposal for File Formats::File_Karma. Comment: 1.) I can't use any name with _CVS_ in it due to the PEAR CS and the fact that you can't create or check in directories named "CVS" into a CVS repository. I'm open to suggestions, but for now I'm keeping it as File_Avail. 2.) I switched from tmpnam() to tmpfile() 3.) flock()? You mean lock the tmp file or the actual avail file? Locking the actual avail file seems dangerous to me as the CVS server would need to read that. 4.) Done 5.) Removed gratuitous @author tags 6.) Done, despite me hating $line{0} ... I think it's less readable, though it is faster. I digress. 7.) Fixed comma spacing throughout 8.) Maybe I'm totally missing what you're saying about checking is_resource(). I actually check twice (in open() and read()). 9.) I did this in a few places. If you notice any I missed I'll go back and fix them. I'll be releasing 0.0.2 soon and updating the package URL. Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=279 -- Sent by PEPr, the automatic proposal system at http://pear.php.net

« previous php.pear.dev (#39502) next »