#19292 [Com]: random error: open_basedir restriction in effect. File is in wrong directory

From: Date: Sun, 12 Jan 2003 11:40:52 +0000
Subject: #19292 [Com]: random error: open_basedir restriction in effect. File is in wrong directory
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-29813@lists.php.net to get a copy of this message
 ID:               19292
 Comment by:       fillon@webstore.fr
 Reported By:      tnowak@triger.com.pl
 Status:           Critical
 Bug Type:         Apache related
 Operating System: linux
 PHP Version:      4.2.3,4.3.0
 New Comment:

Same problem with php 4.3.0 / apache 1.3.27 / Slackware
The problem seems to appear when a virtual host has a open_basedir
defined, but not in other virtualhost. In this case others virtual
hosts take the value of one of defined  open_basedir. (maybe the value
come from another http child open in same time)

Seems to have same behaviour with auto_append.

Hope it will help to solve this bug.

Fred


Previous Comments:
------------------------------------------------------------------------

[2003-01-11 21:33:19] gregory@tiv.net

I have 2 FreeBSD servers with the same problem. Both have /www as
symlink. Real path is /home/www.
I also have a Windows machine, with no symlink ;-) - no problem there.
/www is c:/www there, and all works.
All machines have same httpd.conf, same Apache, same 4.2.3

------------------------------------------------------------------------

[2003-01-11 05:16:38] david@ols.es

4.3.o stills has the same problem, the test suite I posted on 30 Oct
2002 12:56am fails with this messages:

Warning: main() [function.main]: open_basedir restriction in effect.
File(/usr/local/lib/php/hello.php) is not within the allowed path(s):
(/usr/local/http-docs/common/scripts/) in
/usr/local/http-docs/common/lib/test/test.php on line 5

Warning: main(hello.php) [function.main]: failed to create stream: Not
owner in /usr/local/http-docs/common/lib/test/test.php on line 5

Fatal error: main() [function.main]: Failed opening required
'hello.php'
(include_path='./:/usr/local/http-docs/common/lib:/usr/local/lib/php:/usr/local/http-docs/common/lib/phpwhois')
in /usr/local/http-docs/common/lib/test/test.php on
line 5

where test.php tries to include hello.php which is in
/usr/local/http-docs/common/lib/test that is a path that's
included in include_path

------------------------------------------------------------------------

[2003-01-10 04:36:13] edink@php.net

Update version. Bug confirmed in 4.3.0 - final.

------------------------------------------------------------------------

[2003-01-10 03:17:18] r@orcafat.com

Is somebody working on this critical bug in php 4.3.0??

Bug was opened 8 sep and now it isn't even the same year...

This is a severe problem for all hosting companies since they have to
turn of open_basedir to get things going without errors.

------------------------------------------------------------------------

[2003-01-09 12:42:13] michal@feix.cz

I have just tried to EXPLICITLY set "php_admin_flag safe_mode off" to
ALL virtual hosts, which should not be restricted with safe mode and it
seems to help. So the problem is here only when I rely on the default
setting in php.ini file (where I have safe mode off by default) and
when there is AT LEAST one virtual host with safe_mode enabled.

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://bugs.php.net/19292

-- 
Edit this bug report at http://bugs.php.net/?id=19292&edit=1



Thread (107 messages)

« previous php.bugs (#29813) next »