#19292 [Com]: random error: open_basedir restriction in effect. File is in wrong directory
| From: | root at mediamonks dot net | Date: | Mon, 03 Feb 2003 17:07:55 +0000 |
| Subject: | #19292 [Com]: random error: open_basedir restriction in effect. File is in wrong directory | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-31992@lists.php.net to get a copy of this message | ||
ID: 19292
Comment by: root@mediamonks.net
Reported By: tnowak@triger.com.pl
Status: Critical
Bug Type: Apache related
Operating System: linux
PHP Version: 4.2.3,4.3.0
New Comment:
I have about the same problem, I use a restrictive open_basedir by
default, but turn it off for certain vhosts:
php_admin_value open_basedir /
This has always worked for me in 4.2.3, but after upgrading to 4.3.0 I
get open_basedir errors (no changes to php.ini):
-->
Warning: Unknown(): open_basedir restriction in effect.
File(/var/www/hostname/root/admin/phpinfo.php) is not within the
allowed path(s): (/) in Unknown on line 0
Warning: Unknown(/var/www/hostname/root/admin/phpinfo.php): failed to
create stream: Operation not permitted in Unknown on line 0
Warning: Unknown(): Failed opening
'/var/www/hostname/root/admin/phpinfo.php' for inclusion
(include_path='.:/usr/local/lib/php') in Unknown on line 0
-->
This is persistent for me on FreeBSD 4.7-STABLE:
-->
Build Date Feb 3 2003 14:35:44
Configure Command './configure' '--with-apxs=/usr/local/sbin/apxs'
'--with-config-file-path=/usr/local/etc' '--enable-versioning'
'--with-regex=system' '--without-gd' '--without-mysql'
'--with-gd=/usr/local' '--enable-gd-native-ttf'
'--with-freetype-dir=/usr/local' '--with-jpeg-dir=/usr/local'
'--with-png-dir=/usr/local' '--with-zlib' '--with-bz2=/usr'
'--with-mcrypt=/usr/local' '--with-mhash=/usr/local'
'--with-mysql=/usr/local' '--with-expat-dir=/usr/local'
'--with-ming=/usr/local' '--enable-trans-sid' '--prefix=/usr/local'
'i386-portbld-freebsd4.7'
-->
Previous Comments:
------------------------------------------------------------------------
[2003-01-30 09:33:52] aw@mittwaldmedien.de
Same problem, suse 8.1 , apache 1.3.26.
selfcompiled php 4.2.3 updated from 4.2.2
------------------------------------------------------------------------
[2003-01-24 09:11:18] sanry@now.net.cn
I use redhat8.0 and upgrade from php4.12 to php4.2.3
and the file have open_basedir restriction, and after
all the include file is inside the basedir not outside
------------------------------------------------------------------------
[2003-01-20 13:16:28] mitch@karboneye.com
Same problem FreeBSD 4.7p3 PHP 4.3.0 PHP 4.2.3 Apache 1.3.27 (bug
20190)
------------------------------------------------------------------------
[2003-01-17 13:57:47] thibaud@phpnet.org
The same probleme is in php4-STABLE-200301171630
Please correct that....
Warning: Unknown(): open_basedir restriction in effect.
File(/home/ovh/www/forum/list.php) is not within the allowed path(s):
(/home/users/xiaoping) in Unknown on line 0
Warning: Unknown(/home/ovh/www/forum/list.php): failed to create
stream: Operation not permitted in Unknown on line 0
Warning: (null)() [function.include]: Failed opening
'/home/ovh/www/forum/list.php' for inclusion
(include_path='.:/upload/') in Unknown on line 0
------------------------------------------------------------------------
[2003-01-12 05:40:52] fillon@webstore.fr
Same problem with php 4.3.0 / apache 1.3.27 / Slackware
The problem seems to appear when a virtual host has a open_basedir
defined, but not in other virtualhost. In this case others virtual
hosts take the value of one of defined open_basedir. (maybe the value
come from another http child open in same time)
Seems to have same behaviour with auto_append.
Hope it will help to solve this bug.
Fred
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/19292
--
Edit this bug report at http://bugs.php.net/?id=19292&edit=1