#19292 [Ctl->Fbk]: random error: open_basedir restriction in effect. File is in wrong directory

From: Date: Sat, 15 Feb 2003 23:08:55 +0000
Subject: #19292 [Ctl->Fbk]: random error: open_basedir restriction in effect. File is in wrong directory
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-33259@lists.php.net to get a copy of this message
 ID:               19292
 Updated by:       sniper@php.net
 Reported By:      tnowak@triger.com.pl
-Status:           Critical
+Status:           Feedback
 Bug Type:         Apache related
 Operating System: linux
 PHP Version:      4.2.3,4.3.0
 New Comment:

Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

I fixed a bug that prevented resetting the open_basedir
by using 'php_admin_value open_basedir none'. 

This most likely fixes this problem for at least some of
you who have added comments to this report.



Previous Comments:
------------------------------------------------------------------------

[2003-02-05 11:25:59] birdman_@_stones_._com

Have/Had this problem on a Redhat7.1, Apache 1.3.27 and
- php 4.2.3
- php 4.3.0

Finally the solution was to include the '/usr/local/lib/php' to the
open_basedir ruleset, cause of PHP tries to look up the included files
there...somehow and although it's not there after all.

e.g. open_basedir = /wwwroot:/usr/local/lib/php

------------------------------------------------------------------------

[2003-01-24 09:11:18] sanry@now.net.cn

I use redhat8.0   and upgrade from php4.12 to php4.2.3    

and the file have open_basedir restriction,  and after
all the include file is inside the basedir not outside

------------------------------------------------------------------------

[2003-01-20 13:16:28] mitch@karboneye.com

Same problem FreeBSD 4.7p3 PHP 4.3.0 PHP 4.2.3 Apache 1.3.27 (bug
20190)

------------------------------------------------------------------------

[2003-01-17 13:57:47] thibaud@phpnet.org

The same probleme is in php4-STABLE-200301171630

Please correct that....

Warning: Unknown(): open_basedir restriction in effect.
File(/home/ovh/www/forum/list.php) is not within the allowed path(s):
(/home/users/xiaoping) in Unknown on line 0

Warning: Unknown(/home/ovh/www/forum/list.php): failed to create
stream: Operation not permitted in Unknown on line 0

Warning: (null)() [function.include]: Failed opening
'/home/ovh/www/forum/list.php' for inclusion
(include_path='.:/upload/') in Unknown on line 0

------------------------------------------------------------------------

[2003-01-12 05:40:52] fillon@webstore.fr

Same problem with php 4.3.0 / apache 1.3.27 / Slackware
The problem seems to appear when a virtual host has a open_basedir
defined, but not in other virtualhost. In this case others virtual
hosts take the value of one of defined  open_basedir. (maybe the value
come from another http child open in same time)

Seems to have same behaviour with auto_append.

Hope it will help to solve this bug.

Fred

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://bugs.php.net/19292

-- 
Edit this bug report at http://bugs.php.net/?id=19292&edit=1



Thread (107 messages)

« previous php.bugs (#33259) next »