#19292 [Fbk]: random error: open_basedir restriction in effect. File is in wrong directory
| From: | sniper@php.net | Date: | Sun, 23 Feb 2003 22:39:31 +0000 |
| Subject: | #19292 [Fbk]: random error: open_basedir restriction in effect. File is in wrong directory | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-34022@lists.php.net to get a copy of this message | ||
ID: 19292
Updated by: sniper@php.net
Reported By: tnowak at triger dot com dot pl
Status: Feedback
Bug Type: Apache related
Operating System: linux
PHP Version: 4.2.3,4.3.0
New Comment:
[david at ols dot es] submitted some patches which supposedly
fix some of the issues, so please try the latest snapshot from today.
Previous Comments:
------------------------------------------------------------------------
[2003-02-23 12:53:39] david at ols dot es
it seems that is necessary to have all paths that had been defined by
include_path in php.ini also defined in open_basedir , as
_php_stream_fopen_with_path in streams.c
tries to check if the file could be opened in each path defined in
include_path and will fail if one of those directories is not also in
openbasedir (regardless of the fact that the searched file exists or
not in that directory), giving a surrealistic message that says that a
file that does not exists could not be opened due to openbasedir
restrictions
------------------------------------------------------------------------
[2003-02-22 16:13:58] david at ols dot es
patch submited by sniper dot php.net does not solve the problem
------------------------------------------------------------------------
[2003-02-22 15:10:37] david at ols dot es
Note that in the previous error messages, the first one has completly
wrong arguments as /usr/local/http-docs/common/lib/DB.php does not
exist, it is
/usr/local/lib/php/DB.php and the include path is not just
/usr/local/lib/php, it's the one shown in the last error
------------------------------------------------------------------------
[2003-02-22 15:04:11] david at ols dot es
4.3.1 when running squirrelmail 1.2.11 gives this errors:
[22-Feb-2003 20:56:15] PHP Warning: main() [<a
href='http://www.php.net/function.main'>function.main</a>]:
open_basedir restriction in effect.
File(/usr/local/http-docs/common/lib/DB.php) is not within the allowed
path(s): (/usr/local/lib/php) in
/usr/local/http-docs/common/webmail/functions/db_prefs.php on line 35
[22-Feb-2003 20:56:15] PHP Warning: main(DB.php) [<a
href='http://www.php.net/function.main'>function.main</a>]:
failed to
create stream: Not owner in
/usr/local/http-docs/common/webmail/functions/db_prefs.php on line 35
[22-Feb-2003 20:56:15] PHP Fatal error: main() [<a
href='http://www.php.net/function.main'>function.main</a>]:
Failed
opening required 'DB.php'
(include_path='./:/usr/local/http-docs/common/lib:/usr/local/lib/php:/usr/local/http-docs/common/lib/phpwhois')
in /usr/local/http-docs/common/webmail/functions/db_prefs.php on line
35
------------------------------------------------------------------------
[2003-02-18 13:20:52] aw at mittwaldmedien dot de
Now i tested the http://snaps.php.net/php4-STABLE-latest.tar.gz
from today.
same problem like before.
i call the vhost 'www.domain1.de', after that i call a second vhost
from the same server with 'www.domain2.de'.
Now i get the error:
Warning: Unknown(): open_basedir restriction in effect.
File(/home/www/web8/typo3_src-3.5.0/typo3/index.php) is not within the
allowed path(s): (/home/www/confixx/) in Unknown on line 0
www.domain1.de has the base dir: /home/www/confixx/
www.domain2.de hast the base dir: /home/www/web8/
the funny thing for me is, that i have servers with php 4.2.3 witch i
selfcompiled and they work without that problem.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/19292
--
Edit this bug report at http://bugs.php.net/?id=19292&edit=1