#19292 [Com]: random error: open_basedir restriction in effect. File is in wrong directory
| From: | email at futureweb dot at | Date: | Sun, 09 Mar 2003 23:38:48 +0000 |
| Subject: | #19292 [Com]: random error: open_basedir restriction in effect. File is in wrong directory | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-35147@lists.php.net to get a copy of this message | ||
ID: 19292
Comment by: email at futureweb dot at
Reported By: tnowak at triger dot com dot pl
Status: Feedback
Bug Type: Apache related
Operating System: linux
PHP Version: 4.2.3,4.3.0
New Comment:
to the previous comment, i overread it, sorry,
php_admin_value open_basedir none
did the trick. thanks
Previous Comments:
------------------------------------------------------------------------
[2003-03-09 17:17:34] email at futureweb dot at
we have the same problem and figured out the following:
if it is set to: php_admin_value open_basedir /
it gives errors, also for instance php_admin_value open_basedir /etc
but not for
php_admin_value open_basedir /home/ or the user directory...
what lets me wonder what criteria causes this? where would we need to
add other directories.
we use a server config software which automatically sets the
open_basedir to the users directory, so we used so far php_admin_value
open_basedir / to eliminate it for specific costumers where needed.
anything we could do?
------------------------------------------------------------------------
[2003-03-02 21:54:58] kaspars at fabrika dot lv
Please see bug http://bugs.php.net/bug.php?id=22480, as this seems
to
be connected somewhat, but more critical (php source disclosure).
------------------------------------------------------------------------
[2003-02-23 16:39:30] sniper@php.net
[david at ols dot es] submitted some patches which supposedly
fix some of the issues, so please try the latest snapshot from today.
------------------------------------------------------------------------
[2003-02-23 12:53:39] david at ols dot es
it seems that is necessary to have all paths that had been defined by
include_path in php.ini also defined in open_basedir , as
_php_stream_fopen_with_path in streams.c
tries to check if the file could be opened in each path defined in
include_path and will fail if one of those directories is not also in
openbasedir (regardless of the fact that the searched file exists or
not in that directory), giving a surrealistic message that says that a
file that does not exists could not be opened due to openbasedir
restrictions
------------------------------------------------------------------------
[2003-02-22 16:13:58] david at ols dot es
patch submited by sniper dot php.net does not solve the problem
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/19292
--
Edit this bug report at http://bugs.php.net/?id=19292&edit=1