Re: Re: PHP 5.1 (Or How to break tousands of apps outthere)

From: Date: Fri, 25 Nov 2005 11:29:26 +0000
Subject: Re: Re: PHP 5.1 (Or How to break tousands of apps outthere)
References: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15  Groups: php.internals 
Request: Send a blank email to internals+get-20372@lists.php.net to get a copy of this message
On Fri, 25 Nov 2005, Christian Schneider wrote: > Does that mean your code is more important than all the lines of code > out there? You must be kidding. And as you stated yourself your code > hasn't even been released yet. I didn't say that my code is more important, but if we don't get the date class now, we will get it in 5.1.1 and then break your code - so that doesn't really matter. THe only correct solution is to start prefixing the pear date class, as that needs to be done in the long run anyway. > > Besides that, using "Date" and "Timezone" as classnames are the most > > sensible names for those classes and I do not think we should have change > > that. > > By the same logic the function file_get_contents() could be called get(). ? > Using generic names for core functionality in the global name space is a bad > thing, no matter how convenient the name might be. That's a lesson PHP has > learned for function names quite a while ago, let's not repeat the same > mistake for class names. No no, the core reserves the right to name whatever they want, it's the userland code that is responsible for prefixing their classes. Derick

« previous php.internals (#20372) next »