Add a constant to reflect --with-curlwrappers

From: Date: Sun, 31 Mar 2013 13:25:51 +0000
Subject: Add a constant to reflect --with-curlwrappers
Groups: php.internals 
Request: Send a blank email to internals+get-66871@lists.php.net to get a copy of this message
Hey: there are some issues when people run some codes in a php which is compiled with --with-curlwrappers, like #61336, or the recently test script for #64433 (failed when curl wrappers enabled). I know, that the curl wrapper should act the same as php http wrapper, but for now, we need to provide the ability to user, that they can warn if they codes can not run with curl wrappers.. here are some really usages: https://github.com/UnionOfRAD/lithium/issues/59 and http://weizhifeng.net/wrong-with-curlwrappers.html I propose to add a constant : bool CURL_WRAPPERS_ENABLE or, any other better name... objections? thanks -- Laruence Xinchen Hui http://www.laruence.com/

« previous php.internals (#66871) next »