Re: [RFC] Better type names for int64 RFC

From: Date: Fri, 22 Aug 2014 11:27:52 +0000
Subject: Re: [RFC] Better type names for int64 RFC
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-76798@lists.php.net to get a copy of this message
On Fri, 2014-08-22 at 13:16 +0200, Nikita Popov wrote: > Hi internals! > > Today the int64 RFC has been merged, despite objections regarding the > naming changes it introduces. > > As we were not given a chance to resolve this issue before the merge, a > short proposal has been created, which aims to revert all unnecessary > naming changes and instead use type names that are consistent with the > existing code base and expectations: > > https://wiki.php.net/rfc/better_type_names_for_int64 > > Due to the unexpected merge on short notice, with no chance for discussion, > this issue is blocking a number of other patches. As such I ask if we can > move through this RFC with a shortened cycle. I would not appreciate having > to wait three weeks to have a workable codebase again. > > Nikita Morning internals, I'd very much like the same as Nikita; that's expected names, and quickly. Already it is going to be extremely difficult to maintain extensions for <PHP7 and PHP7, we don't need it to get harder, it is not enough to say that "we have to work something out". Fix it, fix it, fix it !! Cheers Joe

« previous php.internals (#76798) next »