Re: [RFC] Better type names for int64 RFC
| From: | Dmitry Stogov | Date: | Sat, 23 Aug 2014 09:43:48 +0000 |
| Subject: | Re: [RFC] Better type names for int64 RFC | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-76833@lists.php.net to get a copy of this message | ||
I think it's ok to keep zend_off_t and zend_size_t as is.
Thanks. Dmitry,
On Fri, Aug 22, 2014 at 4:09 PM, Anatol Belski <anatol.php@belski.net>
wrote:
> Hi Nikita,
>
> On Fri, August 22, 2014 13:16, Nikita Popov wrote:
> > Hi internals!
> >
> >
> > Today the int64 RFC has been merged, despite objections regarding the
> > naming changes it introduces.
> >
> > As we were not given a chance to resolve this issue before the merge, a
> > short proposal has been created, which aims to revert all unnecessary
> > naming changes and instead use type names that are consistent with the
> > existing code base and expectations:
> >
> > https://wiki.php.net/rfc/better_type_names_for_int64
> >
> >
> > Due to the unexpected merge on short notice, with no chance for
> > discussion, this issue is blocking a number of other patches. As such I
> > ask if we can move through this RFC with a shortened cycle. I would not
> > appreciate having to wait three weeks to have a workable codebase again.
> >
> > Nikita
> >
> to be complete, the RFC probably should take in account several new
> identifiers which came in (zend_off_t, zend_stat_t and co.). As their
> naming scheme is probably somewhat different. I've just documented those
> http://git.php.net/?p=php-src.git;a=blob;f=UPGRADING.INTERNALS
> and
> continue.
>
> Regards
>
> Anatol
>
>
>
> --
> PHP Internals - PHP Runtime Development Mailing List
> To unsubscribe, visit: http://www.php.net/unsub.php
>
>