Re: [RFC] Better type names for int64 RFC

From: Date: Fri, 22 Aug 2014 12:10:55 +0000
Subject: Re: [RFC] Better type names for int64 RFC
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-76807@lists.php.net to get a copy of this message
On Fri, Aug 22, 2014 at 1:16 PM, Nikita Popov <nikita.ppv@gmail.com> wrote: > Hi internals! > > Today the int64 RFC has been merged, despite objections regarding the > naming changes it introduces. > > As we were not given a chance to resolve this issue before the merge, a > short proposal has been created, which aims to revert all unnecessary > naming changes and instead use type names that are consistent with the > existing code base and expectations: > > https://wiki.php.net/rfc/better_type_names_for_int64 > > Due to the unexpected merge on short notice, with no chance for discussion, > this issue is blocking a number of other patches. As such I ask if we can > move through this RFC with a shortened cycle. I would not appreciate having > to wait three weeks to have a workable codebase again. I am against what you propose while being open to have better naming. Keeping what we have in 5.x is a huge mistake and will cause many issues, just like what NG does by using the same APIs or macros names but with different argument types. One example is the STR macro, a major pain. And the names of a macro should match what they actually do and the actually types they deal with, not some random totally misleading names. Cheers, -- Pierre @pierrejoye | http://www.libgd.org

« previous php.internals (#76807) next »