Re: [RFC] Better type names for int64 RFC
| From: | Derick Rethans | Date: | Fri, 22 Aug 2014 11:57:50 +0000 |
| Subject: | Re: [RFC] Better type names for int64 RFC | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-76803@lists.php.net to get a copy of this message | ||
On Fri, 22 Aug 2014, Nikita Popov wrote:
> Hi internals!
>
> Today the int64 RFC has been merged, despite objections regarding the
> naming changes it introduces.
>
> As we were not given a chance to resolve this issue before the merge,
> a short proposal has been created, which aims to revert all
> unnecessary naming changes and instead use type names that are
> consistent with the existing code base and expectations:
>
> https://wiki.php.net/rfc/better_type_names_for_int64
>
> Due to the unexpected merge on short notice, with no chance for
> discussion, this issue is blocking a number of other patches. As such
> I ask if we can move through this RFC with a shortened cycle. I would
> not appreciate having to wait three weeks to have a workable codebase
> again.
Yes please.
cheers,
Derick