Re: [RFC] Better type names for int64 RFC
| From: | Pierre Joye | Date: | Sat, 23 Aug 2014 20:13:43 +0000 |
| Subject: | Re: [RFC] Better type names for int64 RFC | ||
| References: | 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-76847@lists.php.net to get a copy of this message | ||
On Sat, Aug 23, 2014 at 9:41 PM, Andrea Faulds <ajf@ajf.me> wrote:
>
> On 23 Aug 2014, at 20:38, Pierre Joye <pierre.php@gmail.com> wrote:
>
>> Please try to port one. That will solve this never ending ping pong
>> game. Extensions are broken per se with ng, almost every zval macros
>> usage must change (some disappeared, like the _PP ones), all hash APIs
>> call must be change (a must, not detectable at compile time), etc.
>> IS_LONG to IS_INT is a joke in comparison. But as nobody agrees on
>> that, I won't discuss it to death.
>
> You previously told me on this list that if I maintained an extension, I’d know that
> replacing macro names with a find/replace is a big deal.
Excatly, and IS_LONG/INT are not macros and a very very tiny change in
comparison to anything else, be ng alone, or ng+int64.
>>> 2. If bigints are implemented, we’d have to rename everything again.
>>
>> Ah, and that will be acceptable then, right? ;-)
>
> It wouldn’t be needless, it would be done to reduce confusion.
>
>> Also hurry up with that, even if not totally completed. Many
>> extensions may have to deal with it and it will just double the
>> porting work if it is not done soon.
>
> I’ll look into it.
If you need help (windows or other), let me know. Want it in :)
Cheers,
--
Pierre
@pierrejoye | http://www.libgd.org