Re: [RFC] Better type names for int64 RFC

From: Date: Fri, 22 Aug 2014 15:32:51 +0000
Subject: Re: [RFC] Better type names for int64 RFC
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-76815@lists.php.net to get a copy of this message
On 22 Aug 2014, at 12:16, Nikita Popov <nikita.ppv@gmail.com> wrote: > As we were not given a chance to resolve this issue before the merge, a > short proposal has been created, which aims to revert all unnecessary > naming changes and instead use type names that are consistent with the > existing code base and expectations: > > https://wiki.php.net/rfc/better_type_names_for_int64 > > Due to the unexpected merge on short notice, with no chance for discussion, > this issue is blocking a number of other patches. As such I ask if we can > move through this RFC with a shortened cycle. I would not appreciate having > to wait three weeks to have a workable codebase again. I’m very much in favour of this RFC. It is not necessary to change the type names after all; if people turn on compiler warnings, they’ll find out what’s broken anyway. -- Andrea Faulds http://ajf.me/

« previous php.internals (#76815) next »