Re: [PEPr] Call for votes on Authentication::OpenID

From: Date: Wed, 08 Feb 2006 20:27:54 +0000
Subject: Re: [PEPr] Call for votes on Authentication::OpenID
References: 1 2 3 4  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-41251@lists.php.net to get a copy of this message
> no, they're not really: > > function Auth_OpenID_ensureDir() { } > function Auth_OpenID_array_get() { } > > should be: > > class Auth_OpenID_Utils > { > function ensureDir() { } > function array_get() { } > } Putting these functions in a class gets us nothing but an extra layer of namespace that we don't need, and it's a misrepresentation of the purpose of those functions. I realize that this may be a personal style conflict, but I'm going to defer to the PEAR coding guidelines here: "Functions should in addition have the package name as a prefix, to avoid name collisions between packages." -- Jonathan Daugherty JanRain, Inc.

« previous php.pear.dev (#41251) next »