Re: [PEPr] +1 for XML::XML_RPC2 (reproposal)

From: Date: Sat, 02 Jul 2005 01:30:19 +0000
Subject: Re: [PEPr] +1 for XML::XML_RPC2 (reproposal)
References: 1 2  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-38418@lists.php.net to get a copy of this message
Greg Beaver wrote:
Greg Beaver (http://pear.php.net/user/cellog) has voted +1 on the proposal for XML::XML_RPC2 (reproposal). Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=259 Vote information: http://pear.php.net/pepr/pepr-vote-show.php?id=259&handle=cellog Comment: voila
Hi all, I was selectively reading posts while away, and didn't notice the pandemonium raised by Pierre about the call for votes. No harm intended with my vote, I simply didn't see the requests to hold off until after the vote was registered. If I can add a bit of reason into this discussion, I'd like to note: 1) in November, Dan was not the lead of XML_RPC, and Stig was. Stig explicitly expressed interest in a new XML_RPC package. 2) there has been PLENTY of review of the code, both on the list and off the list. 3) It has been rewritten 3 times, twice because of my extensive review of the code. I voted +1 because it satisfied all of the issues I had with the earlier incarnations. I don't yet understand Pierre's argument of why it would be a bad idea to have this package in PEAR, although since it does not have a remotely similar API to XML_RPC, perhaps it should be named something else to avoid confusion? XML_RPC2 is fine by me, but I wouldn't mind something like XML_RPC_PHP5 to be absolutely clear. Even PHP5_XML_RPC would be an interesting possibility (also for future packages that are php5-only incarnations of older solutions) Greg

« previous php.pear.dev (#38418) next »