Re: lambda() naming

From: Date: Sat, 03 Jun 2000 15:46:00 +0000
Subject: Re: lambda() naming
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-20126@lists.php.net to get a copy of this message
On Sat, 3 Jun 2000, Andrei Zmievski wrote: > On Sat, 03 Jun 2000, Zeev Suraski wrote: > > > > What do you guys think about the name of lambda()? While it's fairly > > equivalent to its LISP counterpart, I think we can safely assume most > > people won't understand what it means at all (except for it seeming like > > Lambada...). > > Should it be called create_function() or anonymous_function() or > > something? > > No, please, let's keep it lambda(). People will learn - and since Lisp > and Python call it lambda, it'll be familiar to them as well. Never forget that lovely language called Scheme (LISP for morons). anonymous_function() looks more intuitive than lambda(). I think the function should be renamed and the LISP/Python/Scheme fans should get an alias. - Sascha

« previous php.dev (#20126) next »