RE: [PHP-DEV] lambda() naming

From: Date: Sun, 04 Jun 2000 23:17:57 +0000
Subject: RE: [PHP-DEV] lambda() naming
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-20216@lists.php.net to get a copy of this message
> With all due respect to the name 'lambda' and whatever meaning it > has in CS or in math, in LISP or in other languages, create_function() > describes what it does much better, and would make the code much more readable > to the non CS guys, while not impairing the ability of CS guys to understand > what's going on. I see no particular reason to go with 'lambda'. FWIW, this makes perfect sense to me. Just because 'lambda' appears in other languages and disciplines doesn't make its moniker intuitive. From a non-programmer, non-LISP/Python, hated-algebra, php-enthusiast perspective, create_function() seems *quickly understandable by all*. (The #1 highlight of php, I've always thought....) .mike

« previous php.dev (#20216) next »