Re: lambda() naming

From: Date: Sun, 04 Jun 2000 20:44:22 +0000
Subject: Re: lambda() naming
References: 1 2 3 4 5 6 7  Groups: php.dev 
Request: Send a blank email to php-dev+get-20204@lists.php.net to get a copy of this message
Andrei Zmievski wrote: > On Sun, 04 Jun 2000, Andi Gutmans wrote: > > Guys, > > > > I want to change the name of lambda() tomorrow. Let's agree on a name. > > Possibilities people brought up: > > create_funtion() > > new_funtion() > > anonymous_function() > > > > I am for create_function(). > > Well, seeing as nobody is for lambda() (which would make most sense to > me, since I think beginners would not use it at all), create_function() > or new_function() would be fine. I'm for lambda(), I think its unreasonable to cater to the DCD (Dumbest Common Denominator), if the users can't learn what lambda() does, they shouldn't be programming, period. I mean heck, lets go ahead, and change preg_grep to "search_a_list_by_a_pattern_and_return_the_result" or chop to "take_off_the_whitespace_at_the_end_of_this_string()." Sterling

« previous php.dev (#20204) next »