Re: lambda() naming
| From: | Andi Gutmans | Date: | Sat, 03 Jun 2000 18:04:03 +0000 |
| Subject: | Re: lambda() naming | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-20134@lists.php.net to get a copy of this message | ||
At 05:46 PM 6/3/00 +0200, Sascha Schumann wrote:
On Sat, 3 Jun 2000, Andrei Zmievski wrote: On Sat, 03 Jun 2000, Zeev Suraski wrote:I prefer not having aliases and I definitely prefer having a more PHP'ish name such as anonymous_function() or create_function() than a name such as lambda() which is only intuitive to a very small subset of PHP users. Andi --- Andi Gutmans <andi@zend.com> http://www.zend.com/What do you guys think about the name of lambda()? While it's fairly equivalent to its LISP counterpart, I think we can safely assume most people won't understand what it means at all (except for it seeming like Lambada...). Should it be called create_function() or anonymous_function() or something?No, please, let's keep it lambda(). People will learn - and since Lisp and Python call it lambda, it'll be familiar to them as well.Never forget that lovely language called Scheme (LISP for morons).anonymous_function() looks more intuitive than lambda(). I think the function should be renamed and the LISP/Python/Scheme fans should get an alias.