Re: lambda() naming
| From: | Stanislav Malyshev | Date: | Sun, 04 Jun 2000 05:31:47 +0000 |
| Subject: | Re: lambda() naming | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-20157@lists.php.net to get a copy of this message | ||
AG>> no one learns Python at university as far as I know), I never heard of
AG>> lambda().
Contrary to popular opinion, lambda is not LISP-thing. It's functional
calculus thing - lambda-function. Just LISP uses it because it's
functional language. The urban legend tells that LISP creators called it
lambda because they diagreed on how to spell "alpha" - but I think it's
just an urban legend :)
AG>> I am more against having two names for this lambda() function
AG>> than actually calling it lambda(). But I do think it is a better
AG>> idea to call it a more meaningful (IMO) name.
Well, then I'd call it new_function, not anonymous_function - because
a) it's not anonymous indeed - the function returns name and
b) "anonymous" is long and non-trivially spelled word and c) it reminds
new Function syntax in Javascript (for what it worth).
--
Stanislav Malyshev stas@zend.com
+972-3-6139665