[PEPr] Comment on RFC::RFC_PackageVariableNamingConvention
| From: | Joe Stump | Date: | Thu, 04 Aug 2005 19:10:10 +0000 |
| Subject: | [PEPr] Comment on RFC::RFC_PackageVariableNamingConvention | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-39223@lists.php.net to get a copy of this message | ||
Joe Stump (http://pear.php.net/user/jstump) has commented on the proposal for
RFC::RFC_PackageVariableNamingConvention.
Comment:
I totally disagree with the proposal as it stands. One of the following
should be used instead:
1.) Allow the developer to decide their variable naming scheme, but force
them to stick with whatever they choose.
2.) Keep with studlyCap because this is how the CS says functions must be
named. It doesn't make sense to have functions adhere to one standard and
variables adhere to another.
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=282
--
Sent by PEPr, the automatic proposal system at http://pear.php.net