[PEPr] Comment on RFC::RFC_PackageVariableNamingConvention

From: Date: Fri, 05 Aug 2005 15:56:10 +0000
Subject: [PEPr] Comment on RFC::RFC_PackageVariableNamingConvention
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-39255@lists.php.net to get a copy of this message
Stefano F. Rausch (http://pear.php.net/user/sfrausch) has commented on the proposal for RFC::RFC_PackageVariableNamingConvention. Comment: As it stands now, I'm +1 with the one exception: "If there is no strong case for the use of lowercase_and_underscored variable naming (such as backwards compatibility, for example), developers of new packages are strongly urged to follow the studlyCaps convention for non-global variable names." should read "If there is no valid case for the use of lowercase_and_underscored variable naming (such as backwards compatibility, for example), developers of new packages are encouraged to follow the studlyCaps convention for non-global variable names." To make a long story short: consistency within the package is to strive for. Markus: consistency means throughout the package ... using one naming convention for simple variable types and another one for objects and function names is, IMHO, a big no no! Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=282 -- Sent by PEPr, the automatic proposal system at http://pear.php.net

« previous php.pear.dev (#39255) next »