[PEPr] Comment on RFC::RFC_PackageVariableNamingConvention
| From: | Jesper Veggerby | Date: | Fri, 05 Aug 2005 05:53:30 +0000 |
| Subject: | [PEPr] Comment on RFC::RFC_PackageVariableNamingConvention | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-39243@lists.php.net to get a copy of this message | ||
Jesper Veggerby (http://pear.php.net/user/nosey) has commented on the proposal for
RFC::RFC_PackageVariableNamingConvention.
Comment:
How about a "valid reason" instead of "strong case"? A valid reason being
something like your arguments, where "I'm used to..." is not a valid
argument?!
As far as I have understood from this discussion (which IMHO is more or
less irrellevant since OO discourages public attributes in this way - how
can you guarantee the state of the object? you can't!) there are no one
(except for Clay until he changed his mind) who mind having the
lowercase_and_underscored naming scheme.
But I think it is correct to recommend one for new packages (and I'd also
prefer studly/camel-case).
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=282
--
Sent by PEPr, the automatic proposal system at http://pear.php.net