[PEPr] Comment on RFC::RFC_PackageVariableNamingConvention
| From: | Clay Loveless | Date: | Thu, 04 Aug 2005 19:14:29 +0000 |
| Subject: | [PEPr] Comment on RFC::RFC_PackageVariableNamingConvention | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-39226@lists.php.net to get a copy of this message | ||
Clay Loveless (http://pear.php.net/user/clay) has commented on the proposal for
RFC::RFC_PackageVariableNamingConvention.
Comment:
The coding standards already define an underscore preference in its
explanation of global variable names. There is no reason to confuse
developers by recommending studlyCaps for variable naming within packages,
but an underscore-style for global variables.
It makes sense to stick with the precendent established by older PEAR
packages, and by the global variable naming convention.
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=282
--
Sent by PEPr, the automatic proposal system at http://pear.php.net