Re: [PEPr] Comment on RFC::RFC_PackageVariableNamingConvention

From: Date: Thu, 04 Aug 2005 20:05:28 +0000
Subject: Re: [PEPr] Comment on RFC::RFC_PackageVariableNamingConvention
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-39233@lists.php.net to get a copy of this message
On 8/4/05 12:50 PM Pacific Time, Joe Stump (joe@joestump.net) wrote: > /me whips out is "The Elements of Java Style" and finds that humpBack > is the preferred naming scheme for Java. Josh has made the strongest > argument, IMO, for humpBack (or at the very least "keep all your > variables the same"). > I understand that's what Java does, but if I wanted to be writing Java code, I would be. PHP != Java, and I think the language (and PEAR) is mature enough for decisions to be made on this topic without concerning ourselves too much with what the big kids are doing. What's interesting to me is that you (and others) are expressing a lot of concern for following the preferred naming scheme for Java variables, yet few have shown that concern for following the preferred naming scheme for PEAR variables ... Despite the fact that we're talking about writing PEAR packages for the PEAR project. So what does PEAR do? Who cares what anyone else does. The PEAR foundation classes use lowercase_and_underscore, and IMHO other packages (whether they are popular or not) should have followed that example wherever the CS guide was vague. -Clay -- Killersoft.com

« previous php.pear.dev (#39233) next »