Re: [PEPr] Comment on RFC::RFC_PackageVariableNamingConvention
| From: | Joe Stump | Date: | Thu, 04 Aug 2005 19:50:46 +0000 |
| Subject: | Re: [PEPr] Comment on RFC::RFC_PackageVariableNamingConvention | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-39231@lists.php.net to get a copy of this message | ||
/me whips out is "The Elements of Java Style" and finds that humpBack is the preferred naming scheme for Java. Josh has made the strongest argument, IMO, for humpBack (or at the very least "keep all your variables the same").
--Joe
On Aug 4, 2005, at 12:23 PM, Joshua Eichorn wrote:
Joshua Eichorn (http://pear.php.net/user/jeichorn) has commented on the proposal for RFC::RFC_PackageVariableNamingConvention. Comment: Using underscores for variable names also goes against standard OO coding conventions in other languages. I think the rule should just be pick one or the other and stick with it. Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=282 --Sent by PEPr, the automatic proposal system at http://pear.php.net --PEAR Development Mailing List (http://pear.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php