Re: Re: [PEPr] +1 for File Formats::File_CSV_Get
| From: | Michael Gauthier | Date: | Tue, 02 Dec 2008 02:28:14 +0000 |
| Subject: | Re: Re: [PEPr] +1 for File Formats::File_CSV_Get | ||
| References: | 1 2 3 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-51197@lists.php.net to get a copy of this message | ||
On Tue, 2008-12-02 at 09:01 +0900, kazuyoshi tlacaelel wrote:
> Thanks for the votes ; )
>
> Christian, Till. how is this sound?
>
> column > getColumn
> headers > getHeaders
> row > getRow
> rows > getRows
> cell > getCell
> uses > load (also loadable as an optional argument in the contructor method)
> rawArray > getRawArray()
Sounds good. I'd also suggest renaming:
coordinatable() => hasCell()
injectHeaders() => setHeaders()
symmetric() => isSymmetric()
settings() => setConfig()
asymmetry() => getAsymmetricRows()
It would also be nice to be able to optionally pass in the config array
from setConfig() in the constructor you are making.
Also, is connect() (which is a confusing method name) the same as
getRows() with no range specified? If so, the connect() method should be
dropped.
Lastly, is this package intended to be used at all without CSV headers?
You have my conditional vote as well.
Cheers,
Mike