Re: Re: [PEPr] +1 for File Formats::File_CSV_Get
| From: | Kazuyoshi Tlacaelel | Date: | Thu, 18 Dec 2008 11:20:02 +0000 |
| Subject: | Re: Re: [PEPr] +1 for File Formats::File_CSV_Get | ||
| References: | 1 2 3 4 5 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-51328@lists.php.net to get a copy of this message | ||
I see, well if there is no objections or other ideas
about this, I would rename the package to
"File_CSV_DataSource"
I am really trying to make this package downloadable
through the pear cli by the end of this year, is kind of
"my goal kind of thing". Can anybody provide any help
or suggestions on how to proceed?
Looks like I do not have enough karma or permissions.
Also looks like the editing features have been locked
so if I rename the package, that means that I cannot
change the package name on the pear page.
how should I proceed about this?
Thanks Mark!
On 2008/12/18, at 2:33, Mark Wiesemann wrote:
Kazuyoshi Tlacaelel wrote:On 2008/12/17, at 7:15, Michael Gauthier wrote:I like Michael's second suggestion ("File_CSV_DataSource") in its full version. The term "DataSource" is well known in the PEAR repository (at least Structures_DataGrid [yes, I'm biased *g*] and HTML_QuickForm2 use it). Another option would be to name it simply File_CSV2, making it the PHP 5 successor of the existing File_CSV package (CSV write support would need to be added, though). But that should be discussed with the maintainers of that package first, of course. Regards, Mark --http://www.markwiesemann.eu --PEAR Development Mailing List (http://pear.php.net/) To unsubscribe, visit: http://www.php.net/unsub.phpWhat about File_CSV_Table or File_CSV_DataSource?Thanks Mike, I like "DataSource" better I think is easier to understand. what do you think of this one? File_CSV_Data I like it because is easier to read at a glance. Does anybody has ideas on the package name?