Re: Re: [PEPr] +1 for File Formats::File_CSV_Get
| From: | Kazuyoshi Tlacaelel | Date: | Wed, 17 Dec 2008 05:30:44 +0000 |
| Subject: | Re: Re: [PEPr] +1 for File Formats::File_CSV_Get | ||
| References: | 1 2 3 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-51318@lists.php.net to get a copy of this message | ||
On 2008/12/17, at 7:15, Michael Gauthier wrote:
I was just looking at the documentation, and I think I understand where your coming from, yup. I'll remove the aliased methods. I still want to keep the optional loading feature on the constructor though __construct($filename = null) { ... }There is been some discussion with the naming of the methods I am appending the resolution of those mails below.I am opposed to keeping the aliased method names (uses, symmetry, asymmetry). They're not adding functionality and I think they'll only serve to confuse newcomers to the package.
Thanks Mike, I like "DataSource" better I think is easier to understand. what do you think of this one? File_CSV_Data I like it because is easier to read at a glance. Does anybody has ideas on the package name?What about File_CSV_Table or File_CSV_DataSource? Cheers, MikeMark Wieseman's Comment: I share the opinions about the methods naming scheme. I'm also not sure whether "File_CSV_Get" is the best name for this package (but unfortunately I can't provide a better one at the moment).package naming is the real challenge! anybody has any ideas on this?