Re: Discussion of SCM_SVN Proposal
| From: | Tobias Schlitt | Date: | Fri, 16 Apr 2004 05:40:42 +0000 |
| Subject: | Re: Discussion of SCM_SVN Proposal | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-27754@lists.php.net to get a copy of this message | ||
Chuck Hagenbuch wrote:
No, please start naming correctly in the manor of <Category>_<Packagename>. There will be an RFC for correct naming today evening. Regards, Toby -- Tobias Schlitt GPG Key: 0xA6529579 a passion for php http://www.schlitt.infoI agree with Tobias' suggestion that SCM_SVN should perhaps be placed under "Tools and Utilities" instead of a new SCM category. My question, though, is what would the name be? phpDocumentor obviously doesn't adhere to the naming convention (grandfathered in), but new packages there should be ... Tools_*? Utilities_*? Or perhaps both would be acceptable in that category?I don't think the category name should be required as a class prefix. It'd just be unnecessary overhead.