Re: Comments on bugs marked bogus
| From: | Scott Mattocks | Date: | Wed, 27 Jul 2005 17:08:17 +0000 |
| Subject: | Re: Comments on bugs marked bogus | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-38980@lists.php.net to get a copy of this message | ||
Bertrand Mansion wrote:
The only poor coding practice I see is trying to enforce case-sensitivity in a case-insensitive language, and this is probably found in your __autoload() code.Please run the following code fragment and then revise your statement: <?php $var1 = 'test'; $var2 = 'TEST'; if ($var1 == $var2) { echo 'Case Insensitive'; } else { echo 'Case Sensitive'; } ?> is_a may do a case insensitive comparison but it is an exception to the language rule. I would like to hear your arguments stating that using inconsistent class naming is good coding practice.
We won't fix this before an RFC about how to deal with __autoload() and PEAR is written and approved. This is the decision of the lazy maintainers of HTML_QuickForm. Now, if you are not lazy, just write it.Again, what does this issue have to do with how __autoload() is used? An autoload function may have been used to find the problematic line of code but __autoload() is not the source of the problem. While there may be a need for an RFC relating to __autoload(), it is not relavent to the current discussion. I have asked Alexy repeatedly to no avail and now I am asking you. Please provide sound technical reasoning for not changing the code. That is all I want. If you are not going to fix the package, just give us some sort of reason other than "We don't want to" or "It isn't our problem." Something along the lines of "It will break BC because..." will do. Thank you, Scott Mattocks