Re: [rfc] permissions managment
| From: | Bertrand Mansion | Date: | Tue, 13 Aug 2002 15:49:05 +0000 |
| Subject: | Re: [rfc] permissions managment | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-8380@lists.php.net to get a copy of this message | ||
<rashid@ds.pg.gda.pl> wrote :
> how about this:
>
> Auth
> |__ Basic.php
> |__ Simple.php
> |__ Complex.php
> |__ Basic
> |__ Container.php
> |__ Containers
> |__ DB.php
> |__ File.php
> |__ ...
> |__ Simple
> |__ Container.php
> |__ Containers
> |__ DB.php
> |__ File.php
> |__ ...
> |__ Complex
> |__ Container.php
> |__ Containers
> |__ DB.php
> |__ File.php
> |__ ...
>
> where:
> - basic is current Auth class
> - simple is phplib-like class
> - complex is markus wolff`s live user
-1. Martin is right, I forgot about the EvenMoreComplex class. ;)
I guess we should try to forget about generic names like simple, complex and
so on. Markus, why did you call it liveUser in the first place ?
Maybe:
Auth
|__ LiveUser.php (previously called the LoginManager class)
|__ LiveUser
|__ backend_db.php
|__ ...
Bertrand Mansion
Mamasam