Re: [rfc] permissions managment
| From: | Markus Wolff | Date: | Tue, 13 Aug 2002 17:16:18 +0000 |
| Subject: | Re: [rfc] permissions managment | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-8390@lists.php.net to get a copy of this message | ||
On Tue, 13 Aug 2002 17:49:05 +0200
Bertrand Mansion <bmansion@mamasam.com> wrote:
> -1. Martin is right, I forgot about the EvenMoreComplex class. ;)
>
> I guess we should try to forget about generic names like simple, complex and
> so on. Markus, why did you call it liveUser in the first place ?
>
> Maybe:
> Auth
> |__ LiveUser.php (previously called the LoginManager class)
> |__ LiveUser
> |__ backend_db.php
> |__ ...
...and of course the ReallyALotMoreComplexThanTheEvenMoreComplexClass
class :-)
Yep, I agree, the generic names really aren´t the best idea. I initially
called it "LiveUser" because I developed the first much simpler version
of it about a year ago when a client needed an authorisation systems
only for his servers with live websites, so that site users can apply
for an account and can be tracked after each login. That´s all there is
to it.
Regards,
Markus
--
Markus Wolff <wolff@21st.de>