Re: Resurrecting the Function Renaming Thread
| From: | Jim Winstead | Date: | Tue, 06 Feb 2001 02:26:12 +0000 |
| Subject: | Re: Resurrecting the Function Renaming Thread | ||
| Groups: | php.qa | ||
| Request: | Send a blank email to php-qa+get-2234@lists.php.net to get a copy of this message | ||
>>Anyone else want to pipe in on this thread? I believe that the naming is
>>still a significant issue. Just last week Jim - Jim fer diety's sake -
>>made the is_set != isset mistake.
hmm, i missed this comment the first time around. to be fair, i'd consider
it a minor miracle that i didn't try to use defined().
on the function naming issue, i would just suggest that maintaining
consistency with well-known names is a good thing. particular for things
like the string-handling functions. it is very frustrating to hop between
languages that have identical functions with slightly different names.
overall, i think the gain from worrying about this is relatively small.
i'd rather see effort be put into getting pear up to snuff, and adding
those language features that will make pear better (ie, namespaces).
jim