Re: Resurrecting the Function Renaming Thread
| From: | Zak Greant | Date: | Tue, 06 Feb 2001 19:13:07 +0000 |
| Subject: | Re: Resurrecting the Function Renaming Thread | ||
| References: | 1 | Groups: | php.qa |
| Request: | Send a blank email to php-qa+get-2235@lists.php.net to get a copy of this message | ||
Jim Winstead wrote:
> >>Anyone else want to pipe in on this thread? I believe that the naming
is
> >>still a significant issue. Just last week Jim - Jim fer diety's sake -
> >>made the is_set != isset mistake.
>
> hmm, i missed this comment the first time around. to be fair, i'd
consider
> it a minor miracle that i didn't try to use defined().
: )
> on the function naming issue, i would just suggest that maintaining
> consistency with well-known names is a good thing. particular for things
> like the string-handling functions. it is very frustrating to hop between
> languages that have identical functions with slightly different names.
Initially, I am most interested in cleaning up problems with naming
in extensions. People may or may not agree with fixing the names
for early/core functions.
> overall, i think the gain from worrying about this is relatively small.
> i'd rather see effort be put into getting pear up to snuff, and adding
> those language features that will make pear better (ie, namespaces).
The daily individual gain from having sensible and consistent names
for functions will be relatively small. PHP users will have to look at
the manual a few less times per day and may save themselves a
few minutes here and there. In addition, we will avoid a few
mistakes of the isset/is_set kind. I have made that mistake a
number of times. I use isset often enough that I remember that
there is no underscore in the name now. However, there are lots
of functions with similar naming schemes that I don't use often
and still make the mistake with.
In short, I think that making the core language more consistent
should have higher priority than adding loads of external extra
functionality.
--zak
ps - thanks for the feedback Jim!