RE: [PHP-QA] Resurrecting the Function Renaming Thread
| From: | Cynic | Date: | Wed, 07 Feb 2001 17:37:07 +0000 |
| Subject: | RE: [PHP-QA] Resurrecting the Function Renaming Thread | ||
| References: | 1 | Groups: | php.qa |
| Request: | Send a blank email to php-qa+get-2296@lists.php.net to get a copy of this message | ||
At 17:32 7.2. 2001, James Moore wrote the following:
--------------------------------------------------------------
>> All of this is "just" a matter of finding a sensible compromise.
>
> Im very anti loosing my nice lot of C like functions and this is a very
>closed group on this list just wait until you start commiting these changes
>and people get wind of what your thinking about doing, rename functions that
>are not named according to the specs but leave code functions alone, are you
>going to rename echo to output_string? printf to print_formatted, be
>sensible and leave core functions alone.
>
>James
James, I'm active in this thread because I'm interested in
the topic, not to piss you off. There's nothing personal in
this, and I'm not going to go and shove the changed language
down your throat. (Not even if I could.) The people who are
involved in this thread participate because they a) want to
scratch their itch (like me), and b) try to avoid a major
PITA. (YMMV, but honestly, I think we're just hiding our
personal preference behind all the "lots of people with this
and whatnot background".) I'm glad you didn't just turn your
back on the debate, because voices from all the ends of the
spectre are essential.A sign of disagreement is more useful
(and more welcome) than turning away, and than just voting -1.
This thing is nothing easy, and the more I think about it,
the more I scratch my head, but I think we can eventually
find a win-win solution.
Rumor has it camel was designed by a committee. I think that
camel may evolve in the wild as well, and that this is what
happened (and is happening) with PHP. We can try (we're
actually doing it right now) and see if a horse is a possible
output of a committee. And if we come to a conclusion that
it would rather look like an octopus, well, that means that
current state is the best we can achieve, and that's also
good to know.
YMMV, but I think the debate is worth it no matter what the
outcome will be.
BTW, I don't think this change should be made begind a closed
door, either. I was thinking of PHP-QA and PHP-DEV as places
where ideas are brought, hammered, and either percieved as
reasonable, or discarded. The former would then be presented
to the public to vote on. Something like: we were talking
about strlen (just an example), and possible changes/aliases
are str_len and str_length. What do you think? THAT would be
OSS. :))
____________________________________________________________
Cynic:
A member of a group of ancient Greek philosophers who taught
that virtue constitutes happiness and that self control is
the essential part of virtue.
cynic@mail.cz