RE: [PHP-QA] Resurrecting the Function Renaming Thread

From: Date: Wed, 07 Feb 2001 16:41:03 +0000
Subject: RE: [PHP-QA] Resurrecting the Function Renaming Thread
References: 1  Groups: php.qa 
Request: Send a blank email to php-qa+get-2288@lists.php.net to get a copy of this message
> >DONT SCREW UP WHAT WORKS > > Actually, from my POV a language that has bin2hex, dechex and > strtolower has been screwed up somewhat already. Whether this > is one to one to C or not is not an issue for me, and for quite > an amount of people who _don't_ have the C background. Lots of > win32 PHP people have VBS background, not C, which is more > common among the Unix nation. Well this is inconsistant naming and that is part of the cause yes but I dont to type bin_to_hex when bin2hex is just a clear, dechex should really be dec2hex and I agree that should be changed. What you are missing is people already know PHP and it would be a very bad thing for people to have to relearn it. when you begin to get <?php .... $var = mysql_fetch_array($res); $new_var = math_binary_to_hexidecimal($var); output_print_formatted_string("The Hexidecimal Value of $var is %d",$new_var); ?> OK thats taking it to an extreme but its ugly code keep it neat tidy and short and dont touch functions people already know well. Yes rename xsl_processfile to xsl_process_file (totally non existant function) but keep PHP neat. James

« previous php.qa (#2288) next »