Re: Resurrecting the Function Renaming Thread

From: Date: Tue, 06 Feb 2001 23:08:10 +0000
Subject: Re: Resurrecting the Function Renaming Thread
References: 1 2 3 4  Groups: php.qa 
Request: Send a blank email to php-qa+get-2243@lists.php.net to get a copy of this message
At 23:20 6.2. 2001, Zak Greant wrote the following: -------------------------------------------------------------- >Jim Winstead wrote: >[snip] >> (not that i know that anyone has suggested strlen be called str_len.) >[Zak raises guilty hand] I think that you may have missed a few messages in >the thread. : ) I think it should be str_len too. Question is whether such a change is doable. Maybe in PHP 5. (An alias would help, probably.)It should have been str_len from the beginning, in the first place. There should a clear and binding set of rules. But what would you go for with the ctype_* functions? IIRC, they were originally ctype_is* (ctype_isdigit), then just before 4.0.4 went out, Hartmut changed the names to ctype_* (ctype_digit). I thought the should be reverted, but then again, if we wanted a truly unified naming scheme, they should be ctype_is_digit maybe. What do you choose? Internal consistency or similarity to the original C functions? Where's the border you won't want to cross? It was recently decided to go with PHP's naming scheme in case of the new pdflib functions (that is, the PHP extension won't mirror the pdflib API). From a certain point of view, the ctype family of functions is no different. But then again, C is C, and PHP is written in it. But is does this amount to an exception from the rules? I don't know, and basically, I'm just 'thinking aloud'. BTW, during the discussion on php-dev I have seen remarks indicating that many PHP_FALIAS()es could have an impact on the speed of PHP or something. Is this true? Any hard data? :) ____________________________________________________________ Cynic: A member of a group of ancient Greek philosophers who taught that virtue constitutes happiness and that self control is the essential part of virtue. cynic@mail.cz

« previous php.qa (#2243) next »