Re: Resurrecting the Function Renaming Thread
| From: | Hartmut Holzgraefe | Date: | Tue, 06 Feb 2001 23:16:53 +0000 |
| Subject: | Re: Resurrecting the Function Renaming Thread | ||
| References: | 1 2 3 4 5 | Groups: | php.qa |
| Request: | Send a blank email to php-qa+get-2245@lists.php.net to get a copy of this message | ||
Cynic wrote:
> But what would you go for with the ctype_* functions?
> IIRC, they were originally ctype_is* (ctype_isdigit), then
> just before 4.0.4 went out, Hartmut changed the names to
> ctype_* (ctype_digit).
the original names where the c-names (isdigit()...)
i changed them just before 4.0.4 to be more naming convention
compliant but somehow i missed the obvious :(
and, to blame me even more, i marked them as PHP_EXPERIMENTAL in the
code but did not add any of the mechanisms i had thought and talked
about before to make use of the PHP_EXPERIMENTAL makros or to reject
extensions from release packing if they have an EXPERIMENTAL file in
their ext-directory ;(
--
Hartmut Holzgraefe hartmut@six.de http://www.six.de
+49-711-99091-77
Besuchen Sie uns auf der CeBIT 2001 - in Halle 6 Stand F62/4