Re: Direction for the Function Renaming Effort
| From: | Phil Driscoll | Date: | Wed, 07 Feb 2001 11:47:31 +0000 |
| Subject: | Re: Direction for the Function Renaming Effort | ||
| Groups: | php.qa | ||
| Request: | Send a blank email to php-qa+get-2268@lists.php.net to get a copy of this message | ||
+1 to getting the language consistent
I think there should be a no compromise pure version of the language - the
unaliased (and quickest?) version, but existing stuff should remain
available as an alias.
We haven't so far discussed the order of function parameters. Consistent and
guessable is good enough for me.
Nor have we discussed how much user code we will break by invading the
namespace with string_tokenise() etc. I suspect that a php.ini switch may be
required to enable the new pure naming scheme. Alternatively, a tool would
have to be written to automagically fix existing scripts.
Cheers
--
Phil Driscoll
Dial Solutions
+44 (0)113 294 5112
http://www.dialsolutions.com
http://www.dtonline.org