Re: Direction for the Function Renaming Effort

From: Date: Wed, 07 Feb 2001 19:07:34 +0000
Subject: Re: Direction for the Function Renaming Effort
References: 1  Groups: php.qa 
Request: Send a blank email to php-qa+get-2306@lists.php.net to get a copy of this message
Hello Phil! Phil Driscoll wrote: [snip] > I think there should be a no compromise pure version of the language - the > unaliased (and quickest?) version, but existing stuff should remain > available as an alias. I think that this is more complicated than what we are discussing here, but is definately related. What do you think this version would entail and how would we implement it? > We haven't so far discussed the order of function parameters. Consistent and > guessable is good enough for me. I don't know that we can go back and fix anything - however, having a standard guideline for argument order would probably be a good thing. > Nor have we discussed how much user code we will break by invading the > namespace with string_tokenise() etc. I suspect that a php.ini switch may be > required to enable the new pure naming scheme. Alternatively, a tool would > have to be written to automagically fix existing scripts. True - we should add these to the to-do list (assuming that we all survive this discussion ;) --zak

« previous php.qa (#2306) next »