RE: [PHP-QA] Resurrecting the Function Renaming Thread

From: Date: Tue, 06 Feb 2001 23:21:16 +0000
Subject: RE: [PHP-QA] Resurrecting the Function Renaming Thread
References: 1  Groups: php.qa 
Request: Send a blank email to php-qa+get-2244@lists.php.net to get a copy of this message
> Jim Winstead wrote: > [snip] > > (not that i know that anyone has suggested strlen be called str_len.) > [Zak raises guilty hand] I think that you may have missed a few > messages in > the thread. : ) > > > feel free to disagree. i really don't care enough to argue > > about it. > > Understood - thanks for your input - feel free to speak up if your mind > changes later on in the process! This is where I came unstuck and kinda stopped, there are about 75% of misnamed functions that blaitantly need renaming and its obvious what it should be renamed to... BUT what about functions like gethostbyaddr(), a poor example but a lot of people know it but that name and if it becomes dns_addr_get_by_host or whatever then I do not think that would be a good thing, rename the obvious ones, leave the ones which have well known C counterparts (of course add a nice alias to its correct systematic naming) but dont be over zellous.. For those that have studied chemistry to any higher level (or even those who havnt). I think we should stick to systematic naming scheme as much as possible and enforce it for new functions but not for all. What if the chemists had thought of renaming everything by their new Sytematic naming scheme and enforcing it. Now a commonly used chemical known as EDTA (a Ligand) would have to be refered to as 1,2-bis[bis(carboxymethyl)amino]ethane it would be silly when everyone knows that EDTA is infact this compound and what it does and would you know that hydroxonium is water?? KISS if a function is so well known by its non-systematic name then dont change it.. change it where possible and appropriate. James

« previous php.qa (#2244) next »