Re: Need new name for connect_object()

From: Date: Sun, 20 Mar 2005 16:43:41 +0000
Subject: Re: Need new name for connect_object()
References: 1  Groups: php.gtk.dev 
Request: Send a blank email to php-gtk-dev+get-1020@lists.php.net to get a copy of this message
connect_vanilla() connect_simple() connect_pure() What exactly does connect_swapped() do? ----- Original Message ----- From: "Andrei Zmievski" <andrei@gravitonic.com> To: "PHP-GTK Dev" <php-gtk-dev@lists.php.net> Sent: Sunday, March 20, 2005 4:04 AM Subject: [PHP-GTK-DEV] Need new name for connect_object() > I just realized that Gtk+ 2 does not have a function called > connect_object() - it has something called connect_swapped(). I think > connect_object() name is really misleading; if anything, it does not > pass the signal object, contrary to the name. So, I'd like to deprecate > it and make a new method. So far I came up with connect_direct() and > connect_without(). Any others? > > -Andrei > > -- > PHP-GTK Development Mailing List (http://gtk.php.net/) > To unsubscribe, visit: http://www.php.net/unsub.php >

« previous php.gtk.dev (#1020) next »