Re: Need new name for connect_object()
| From: | Steph | Date: | Mon, 21 Mar 2005 21:13:55 +0000 |
| Subject: | Re: Need new name for connect_object() | ||
| References: | 1 2 3 4 5 | Groups: | php.gtk.dev |
| Request: | Send a blank email to php-gtk-dev+get-1033@lists.php.net to get a copy of this message | ||
I'm failing to see the difference between 2) and 3) here... am I being dim?
And yes, it's very definitely useful behaviour :)
----- Original Message -----
From: "Andrei Zmievski" <andrei@gravitonic.com>
To: "Madeleine D." <mmdrake@bctonline.com>
Cc: "PHP-GTK Dev" <php-gtk-dev@lists.php.net>
Sent: Monday, March 21, 2005 9:02 PM
Subject: Re: [PHP-GTK-DEV] Need new name for connect_object()
> Not really. What it does currently is "omit" the signal object, passes
> the rest of parameters, adding on the user specified-ones at the end.
> So, if originally the parameters to be passed were ($signal_widget,
> $col, $row), and we connect it as:
>
> $w->connect_object('foo', 'myfoo', $myobj);
>
> the parameters it'll pass are ($col, $row, $myobj).
>
> I guess what I am asking is whether this behavior is useful at all, or
> if we would rather really substitute the user specified object instead
> of the signal one, or not pass any signal parameters at all, or what.
> Or maybe have a connection function for all three cases:
>
> 1) connect normally: pass signal widget plus additional signal-specific
> parameters
> 2) connect replace: substitute user-specified object instead of the
> signal one, and pass additional signal-specific parameters
> 3) connect simple: pass only user specified parameters
>
> -Andrei
>
> On Mar 21, 2005, at 11:29 AM, Madeleine D. wrote:
>
> > I'm probably being too simplistic here, but what about
> >
> > connect_other()
> >
> > since it does the same things as connect, including parms, but it does
> > it
> > for another object.
> >
> > Madeleine D.
> >
>
> --
> PHP-GTK Development Mailing List (http://gtk.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
>