Re: Need new name for connect_object()
| From: | Andrei Zmievski | Date: | Mon, 21 Mar 2005 21:18:25 +0000 |
| Subject: | Re: Need new name for connect_object() | ||
| References: | 1 2 3 4 5 6 | Groups: | php.gtk.dev |
| Request: | Send a blank email to php-gtk-dev+get-1034@lists.php.net to get a copy of this message | ||
function my_callback()
{
var_dump(func_get_args());
}
Suppose the signal parameters are (signal_widget, row, col).
2) $o->connect_replace('signal', 'my_callback', $myobj, $arg1, arg2);
The output of var_dump() here would be: $myobj, $row, $col, $arg1, $arg2.3) $o->connect_simple('signal', 'my_callback', $myobj, $arg1, $arg2);
The output here would be: $myobj, $arg1, $arg2.-Andrei On Mar 21, 2005, at 1:13 PM, Steph wrote:
I'm failing to see the difference between 2) and 3) here... am I being dim? And yes, it's very definitely useful behaviour :)1) connect normally: pass signal widget plus additional signal-specific parameters 2) connect replace: substitute user-specified object instead of the signal one, and pass additional signal-specific parameters 3) connect simple: pass only user specified parameters -Andrei