Re: Need new name for connect_object()
| From: | Madeleine D. | Date: | Mon, 21 Mar 2005 19:29:30 +0000 |
| Subject: | Re: Need new name for connect_object() | ||
| References: | 1 2 3 | Groups: | php.gtk.dev |
| Request: | Send a blank email to php-gtk-dev+get-1030@lists.php.net to get a copy of this message | ||
I'm probably being too simplistic here, but what about
connect_other()
since it does the same things as connect, including parms, but it does it
for another object.
Madeleine D.
At 09:40 AM 3/21/05 -0800, you wrote:
>Actually, it does pass the rest of signal arguments. So, if normally it
>passes, for example:
>
>function ($widget, $row, $col)
>{
>}
>
>Then connect_object() would invoke it with only $row and $col. Don't
>know if it makes sense..
>
>On Mon, 21 Mar 2005, Scott Mattocks wrote:
>> Andrei Zmievski wrote:
>> >it and make a new method. So far I came up with connect_direct() and
>> >connect_without(). Any others?
>>
>> Since it only passes user defined parameters
>> connect_user_only()
>>
>> Since it doesn't pass the signal
>> connect_no_signal()
>>
>> Since it doesn't pass any system defined parameters
>> connect_no_system()
>>
>> Scott
>
>
>
>- Andrei
>
>--
>PHP-GTK Development Mailing List (http://gtk.php.net/)
>To unsubscribe, visit: http://www.php.net/unsub.php
>
>